use strict;
my $str = '"A", "B", "C - "G"", "D, F", 5, "A", "B", "C - "G"", "D,F,"G"F,Z,K", "A", "B", "C - "G"", "B", "C - "G"", "D,F,"G"F,Z,K", 1,"A",5, A,"D,8"';
my $regex = qr/(?|"((?:(?!",).)*)"|\h*([^,"]+))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}