import re
regex = re.compile(r"(?<= |^)(\S+)(?: \1){2,}", flags=re.MULTILINE)
test_str = ("he he hemisphere\n"
"hi- hi- hi-tech")
subst = "\\1 \\1"
result = regex.sub(subst, test_str)
if result:
print(result)