import Foundation
let pattern = #"(?<= |^)(\S+)(?: \1){2,}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
he he hemisphere
hi- hi- hi-tech
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 \1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)