re = /(?<= |^)(\S+)(?: \1){2,}/m
str = 'he he hemisphere
hi- hi- hi-tech'
subst = '\\1 \\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result