# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<= |^)(\S+)(?: \1){2,}(?= |$)/\1 \1/gm;t' <<< "hi hi hi hi some words words words which'll repeat repeat repeat repeat repeat
t.he he hemisphere
bye! bye! bye!
he he he he hemisphere"