#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<= |^)(\S+)(?: \1){2,}(?= |$)"
Local $sString = "hi hi hi hi some words words words which'll repeat repeat repeat repeat repeat" & @CRLF & _
"t.he he hemisphere" & @CRLF & _
"bye! bye! bye!" & @CRLF & _
"he he he he hemisphere"
Local $sSubst = "\1 \1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)