import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<= |^)(\\S+)(?: \\1){2,}(?= |$)";
final String string = "hi hi hi hi some words words words which'll repeat repeat repeat repeat repeat\n"
+ "t.he he hemisphere\n"
+ "bye! bye! bye!\n"
+ "he he he he hemisphere";
final String subst = "\\1 \\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}