# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<= |^)(\S+)(?: \1){2,}(?= |$)"
test_str = ("hi hi hi hi some words words words which'll repeat repeat repeat repeat repeat\n"
"t.he he hemisphere\n"
"bye! bye! bye!\n"
"he he he he hemisphere")
subst = "\\1 \\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.