using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<= |^)(\S+)(?: \1){2,}(?= |$)";
string substitution = @"\1 \1";
string input = @"hi hi hi hi some words words words which'll repeat repeat repeat repeat repeat
t.he he hemisphere
bye! bye! bye!
he he he he hemisphere";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}