use strict;
my $str = 'hi hi hi hi some words words words which\'ll repeat repeat repeat repeat repeat
t.he he hemisphere
bye! bye! bye!
he he he he hemisphere';
my $regex = qr/(?<= |^)(\S+)(?: \1){2,}(?= |$)/mp;
my $subst = '\\1 \\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";