$re = '/(?<= |^)(\S+)(?: \1){2,}(?= |$)/m';
$str = 'hi hi hi hi some words words words which\'ll repeat repeat repeat repeat repeat
t.he he hemisphere
bye! bye! bye!
he he he he hemisphere';
$subst = "\1 \1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;