const regex = new RegExp('(?<= |^)(\\S+)(?: \\1){2,}(?= |$)', 'gm')
const str = `hi hi hi hi some words words words which'll repeat repeat repeat repeat repeat
t.he he hemisphere
bye! bye! bye!
he he he he hemisphere`;
const subst = `\1 \1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);