using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*v[0]*([0-9]+)\.[0]*([0-9]+)\.[0]*([0-9]+).*";
string input = @"v01.02.03
v1.2.3
v1.2a
v1.00.2
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}