package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*v[0]*([0-9]+)\.[0]*([0-9]+)\.[0]*([0-9]+).*`)
var str = `v01.02.03
v1.2.3
v1.2a
v1.00.2
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}