// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*v[0]*([0-9]+)\.[0]*([0-9]+)\.[0]*([0-9]+).*").unwrap();
let string = "v01.02.03
v1.2.3
v1.2a
v1.00.2
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}