re = /.*v[0]*([0-9]+)\.[0]*([0-9]+)\.[0]*([0-9]+).*/
str = 'v01.02.03
v1.2.3
v1.2a
v1.00.2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end