const regex = /.*v[0]*([0-9]+)\.[0]*([0-9]+)\.[0]*([0-9]+).*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*v[0]*([0-9]+)\\.[0]*([0-9]+)\\.[0]*([0-9]+).*', 'g')
const str = `v01.02.03
v1.2.3
v1.2a
v1.00.2
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}