import re
regex = re.compile(r".*v[0]*([0-9]+)\.[0]*([0-9]+)\.[0]*([0-9]+).*")
test_str = ("v01.02.03\n"
"v1.2.3\n"
"v1.2a\n"
"v1.00.2\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")