import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*v[0]*([0-9]+)\\.[0]*([0-9]+)\\.[0]*([0-9]+).*";
final String string = "v01.02.03\n"
+ "v1.2.3\n"
+ "v1.2a\n"
+ "v1.00.2\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}