#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[[:alnum:]]+(?:\.\d+)*"
Local $sString = "January.313" & @CRLF & _
"January" & @CRLF & _
"January.31.Feb.6" & @CRLF & _
"GMI3.0.N.1" & @CRLF & _
"January.31.Feb.6.March.7" & @CRLF & _
"April.May"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")