import re
regex = re.compile(r"[[:alnum:]]+(?:\.\d+)*", flags=re.MULTILINE)
test_str = ("January.313\n"
"January\n"
"January.31.Feb.6\n"
"GMI3.0.N.1\n"
"January.31.Feb.6.March.7\n"
"April.May")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")