import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[[:alnum:]]+(?:\\.\\d+)*";
final String string = "January.313\n"
+ "January\n"
+ "January.31.Feb.6\n"
+ "GMI3.0.N.1\n"
+ "January.31.Feb.6.March.7\n"
+ "April.May";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}