package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[[:alnum:]]+(?:\.\d+)*`)
var str = `January.313
January
January.31.Feb.6
GMI3.0.N.1
January.31.Feb.6.March.7
April.May`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}