using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[[:alnum:]]+(?:\.\d+)*";
string input = @"January.313
January
January.31.Feb.6
GMI3.0.N.1
January.31.Feb.6.March.7
April.May";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}