re = /[[:alnum:]]+(?:\.\d+)*/m
str = 'January.313
January
January.31.Feb.6
GMI3.0.N.1
January.31.Feb.6.March.7
April.May'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end