$re = '/[[:alnum:]]+(?:\.\d+)*/m';
$str = 'January.313
January
January.31.Feb.6
GMI3.0.N.1
January.31.Feb.6.March.7
April.May';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);