// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[[:alnum:]]+(?:\.\d+)*").unwrap();
let string = "January.313
January
January.31.Feb.6
GMI3.0.N.1
January.31.Feb.6.March.7
April.May";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}