#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(^|[^\n])\n{2}"
Local $sString = "1234" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"5678" & @CRLF & _
""
Local $sSubst = "TEST"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)