$re = '/(^|[^\n])\n{2}/';
$str = '1234
5678
';
$subst = "TEST";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;