// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(^|[^\n])\n{2}").unwrap();
let string = "1234
5678
";
let substitution = "TEST";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}