package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^|[^\n])\n{2}`)
var str = `1234
5678
`
var substitution = "TEST"
fmt.Println(re.ReplaceAllString(str, substitution))
}