import Foundation
let pattern = #"(^|[^\n])\n{2}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1234
5678
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"TEST"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)