const regex = /(^|[^\n])\n{2}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^|[^\\n])\\n{2}', 'g')
const str = `1234
5678
`;
const subst = `TEST`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);