using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^|[^\n])\n{2}";
string substitution = @"TEST";
string input = @"1234
5678
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}