#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".*((?:January|February|March|April|May|June|July|August|September|October|November|December) \d\d?)"
Local $sString = "3 Day Pass Tickets (September 27 - September 29 - 21+ Event)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")