re = /.*((?:January|February|March|April|May|June|July|August|September|October|November|December) \d\d?)/
str = '3 Day Pass Tickets (September 27 - September 29 - 21+ Event)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end