using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*((?:January|February|March|April|May|June|July|August|September|October|November|December) \d\d?)";
string input = @"3 Day Pass Tickets (September 27 - September 29 - 21+ Event)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}