// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*((?:January|February|March|April|May|June|July|August|September|October|November|December) \d\d?)").unwrap();
let string = "3 Day Pass Tickets (September 27 - September 29 - 21+ Event)";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}