import Foundation
let pattern = #".*((?:January|February|March|April|May|June|July|August|September|October|November|December) \d\d?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"3 Day Pass Tickets (September 27 - September 29 - 21+ Event)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}