$re = '/.*((?:January|February|March|April|May|June|July|August|September|October|November|December) \d\d?)/';
$str = '3 Day Pass Tickets (September 27 - September 29 - 21+ Event)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);