use strict;
my $str = '3 Day Pass Tickets (September 27 - September 29 - 21+ Event)';
my $regex = qr/.*((?:January|February|March|April|May|June|July|August|September|October|November|December) \d\d?)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}