package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*((?:January|February|March|April|May|June|July|August|September|October|November|December) \d\d?)`)
var str = `3 Day Pass Tickets (September 27 - September 29 - 21+ Event)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}