using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?i)\b\d{9}[a-z]?[^\W_]?\d{0,3}\b$";
string input = @"123456789A1
123456789AA
123456789AA123
123456789A1123
12345678911234
123456789AA12345";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}