use strict;
my $str = '123456789A1
123456789AA
123456789AA123
123456789A1123
12345678911234
123456789AA12345';
my $regex = qr/^(?i)\b\d{9}[a-z]?[^\W_]?\d{0,3}\b$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}