$re = '/^(?i)\b\d{9}[a-z]?[^\W_]?\d{0,3}\b$/m';
$str = '123456789A1
123456789AA
123456789AA123
123456789A1123
12345678911234
123456789AA12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);