// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?i)\b\d{9}[a-z]?[^\W_]?\d{0,3}\b$").unwrap();
let string = "123456789A1
123456789AA
123456789AA123
123456789A1123
12345678911234
123456789AA12345";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}