re = /^(?i)\b\d{9}[a-z]?[^\W_]?\d{0,3}\b$/m
str = '123456789A1
123456789AA
123456789AA123
123456789A1123
12345678911234
123456789AA12345'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end