package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?i)\b\d{9}[a-z]?[^\W_]?\d{0,3}\b$`)
var str = `123456789A1
123456789AA
123456789AA123
123456789A1123
12345678911234
123456789AA12345`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}