const regex = /^(?i)\b\d{9}[a-z]?[^\W_]?\d{0,3}\b$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?i)\\b\\d{9}[a-z]?[^\\W_]?\\d{0,3}\\b$', 'gm')
const str = `123456789A1
123456789AA
123456789AA123
123456789A1123
12345678911234
123456789AA12345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}