import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?:\\/\\/\\S+)$";
final String string = "<div class=\"text\">\n"
+ "http://2gis.ru\n"
+ "http://www.yp.ru\n"
+ "http://www.yell.ru\n"
+ "http://www.ypag.ru\n"
+ "http://www.e-adres.ru\n"
+ "http://infolo.ru\n"
+ "http://globalmcom.com\n"
+ "</div>";
final String subst = "$1<br>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}